const regex = /\((?:[^()]++|(?R))*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((?:[^()]++|(?R))*\\)', 'g')
const str = `(pop+corn)-bread+salt
(pop+corn+unicorn)-bread+salt+malt
(pop(+corn)+unicorn)-bread+salt+malt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}