package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?:[^()]++|(?R))*\)`)
var str = `(pop+corn)-bread+salt
(pop+corn+unicorn)-bread+salt+malt
(pop(+corn)+unicorn)-bread+salt+malt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}