re = /\((?:[^()]++|(?R))*\)/
str = '(pop+corn)-bread+salt
(pop+corn+unicorn)-bread+salt+malt
(pop(+corn)+unicorn)-bread+salt+malt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end