#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<client>\w*)(?:-?(?<environment>\w*)?)\.(?<domain>[\w-]*\.\w*)\s*$"
Local $sString = "wd.commloanservices.net" & @CRLF & _
"wd.commloanservices.net" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"bin.agamerica-qa.commloanservices.com" & @CRLF & _
"gf0.agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica-qa.commloanservices.com" & @CRLF & _
"agamerica.commloanservices.com" & @CRLF & _
"agamerica.commloanservices.com" & @CRLF & _
"agamerica.commloanservices.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")