import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<client>\\w*)(?:-?(?<environment>\\w*)?)\\.(?<domain>[\\w-]*\\.\\w*)\\s*$";
final String string = "wd.commloanservices.net\n"
+ "wd.commloanservices.net\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "bin.agamerica-qa.commloanservices.com\n"
+ "gf0.agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica-qa.commloanservices.com\n"
+ "agamerica.commloanservices.com\n"
+ "agamerica.commloanservices.com\n"
+ "agamerica.commloanservices.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}