package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<client>\w*)(?:-?(?<environment>\w*)?)\.(?<domain>[\w-]*\.\w*)\s*$`)
var str = `wd.commloanservices.net
wd.commloanservices.net
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
bin.agamerica-qa.commloanservices.com
gf0.agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica.commloanservices.com
agamerica.commloanservices.com
agamerica.commloanservices.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}