use strict;
my $str = 'Technology libraries: Techlibhellohellohello
Technology libraries: Techlibhellohellohello';
my $regex = qr/(Technology libraries)(:\s+)(.*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";