# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^\t](.*?)(?=\t)/<div id="abc-box"><a name="$1">$1<\/a><\/div>/gm;t' <<< "[ 0-9 ] 1984
2 mothers in a h d b playground
2001: A Space Odyssey
42nd Street
4-H
50 Cent
60 Minutes
A A
A
A 1
A cappella
A.D.
"