$re = '/^[^\t](.*?)(?=\t)/m';
$str = '[ 0-9 ] 1984
2 mothers in a h d b playground
2001: A Space Odyssey
42nd Street
4-H
50 Cent
60 Minutes
A A
A
A 1
A cappella
A.D.
';
$subst = "<div id=\"abc-box\"><a name=\"$1\">$1</a></div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;