using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\t](.*?)(?=\t)";
string substitution = @"<div id=""abc-box""><a name=""$1"">$1</a></div>";
string input = @"[ 0-9 ] 1984
2 mothers in a h d b playground
2001: A Space Odyssey
42nd Street
4-H
50 Cent
60 Minutes
A A
A
A 1
A cappella
A.D.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}