import Foundation
let pattern = #"^[^\t](.*?)(?=\t)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[ 0-9 ] 1984
2 mothers in a h d b playground
2001: A Space Odyssey
42nd Street
4-H
50 Cent
60 Minutes
A A
A
A 1
A cappella
A.D.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<div id="abc-box"><a name="$1">$1</a></div>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)