import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\t](.*?)(?=\\t)";
final String string = "[ 0-9 ] 1984\n"
+ " 2 mothers in a h d b playground\n"
+ " 2001: A Space Odyssey\n"
+ " 42nd Street\n"
+ " 4-H\n"
+ " 50 Cent\n"
+ " 60 Minutes\n"
+ "A A\n"
+ " A\n"
+ " A 1\n"
+ " A cappella\n"
+ " A.D.\n";
final String subst = "<div id=\"abc-box\"><a name=\"$1\">$1</a></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}