#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$"
Local $sString = "verison.com" & @CRLF & _
"verison.net" & @CRLF & _
"verison.nte" & @CRLF & _
"verizon" & @CRLF & _
"verizon.com" & @CRLF & _
"verizon.cpm" & @CRLF & _
"verizon.ent" & @CRLF & _
"verizon.met" & @CRLF & _
"verizon.nbet" & @CRLF & _
"verizon.ne" & @CRLF & _
"verizon.net" & @CRLF & _
"verizon.net." & @CRLF & _
"verizon.net.com" & @CRLF & _
"verizon.netjac" & @CRLF & _
"verizon.netormdeb" & @CRLF & _
"verizon.netosunnam" & @CRLF & _
"verizon.nmet" & @CRLF & _
"verizon.org" & @CRLF & _
"verizoncom" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")