re = /^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$/m
str = 'verison.com
verison.net
verison.nte
verizon
verizon.com
verizon.cpm
verizon.ent
verizon.met
verizon.nbet
verizon.ne
verizon.net
verizon.net.
verizon.net.com
verizon.netjac
verizon.netormdeb
verizon.netosunnam
verizon.nmet
verizon.org
verizoncom
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end