// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$").unwrap();
let string = "verison.com
verison.net
verison.nte
verizon
verizon.com
verizon.cpm
verizon.ent
verizon.met
verizon.nbet
verizon.ne
verizon.net
verizon.net.
verizon.net.com
verizon.netjac
verizon.netormdeb
verizon.netosunnam
verizon.nmet
verizon.org
verizoncom
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}