# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^veri[sz]on.(net|nte)$|^veri[sz]on(net)?$"
test_str = ("verison.com\n"
"verison.net\n"
"verison.nte\n"
"verizon\n"
"verizon.com\n"
"verizon.cpm\n"
"verizon.ent\n"
"verizon.met\n"
"verizon.nbet\n"
"verizon.ne\n"
"verizon.net\n"
"verizon.net.\n"
"verizon.net.com\n"
"verizon.netjac\n"
"verizon.netormdeb\n"
"verizon.netosunnam\n"
"verizon.nmet\n"
"verizon.org\n"
"verizoncom\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.