using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>https?:|)[^:;\n]+[:;](.*)";
string substitution = @"$1";
string input = @"www.yahoo.com:описание1
http://site.ru:описание2
www.site3.org:описание3
http://w3k.biz:описание4
www.yahoo.su:описание5
http://w3k.biz;описание6
www.yahoo.su;описание7";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}