# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>https?:|)[^:;\n]+[:;](.*)"
test_str = ("www.yahoo.com:описание1\n"
"http://site.ru:описание2\n"
"www.site3.org:описание3\n"
"http://w3k.biz:описание4\n"
"www.yahoo.su:описание5\n"
"http://w3k.biz;описание6\n"
"www.yahoo.su;описание7")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.