import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>https?:|)[^:;\\n]+[:;](.*)";
final String string = "www.yahoo.com:описание1\n"
+ "http://site.ru:описание2\n"
+ "www.site3.org:описание3\n"
+ "http://w3k.biz:описание4\n"
+ "www.yahoo.su:описание5\n"
+ "http://w3k.biz;описание6\n"
+ "www.yahoo.su;описание7";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}