import Foundation
let pattern = #"^(?>https?:|)[^:;\n]+[:;](.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
www.yahoo.com:описание1
http://site.ru:описание2
www.site3.org:описание3
http://w3k.biz:описание4
www.yahoo.su:описание5
http://w3k.biz;описание6
www.yahoo.su;описание7
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)