const regex = /^(?>https?:|)[^:;\n]+[:;](.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>https?:|)[^:;\\n]+[:;](.*)', 'gm')
const str = `www.yahoo.com:описание1
http://site.ru:описание2
www.site3.org:описание3
http://w3k.biz:описание4
www.yahoo.su:описание5
http://w3k.biz;описание6
www.yahoo.su;описание7`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);