#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) *[\.\?!][\'"\)\]]*[ |\n](?=[A-Z])"
Local $sString = "Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles." & @CRLF & _
"" & @CRLF & _
"Anna and her family love doing puzzles." & @CRLF & _
"Anna is best at little puzzles." & @CRLF & _
"Anna and her family love doing puzzles." & @CRLF & _
"Anna is best at little puzzles." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles." & @CRLF & _
"" & @CRLF & _
"Anna and her family love doing puzzles." & @CRLF & _
"" & @CRLF & _
"Anna is best at little puzzles." & @CRLF & _
"" & @CRLF & _
"Anna and her family love doing puzzles." & @CRLF & _
"" & @CRLF & _
"Anna is best at little puzzles."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")