using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *[\.\?!][\'""\)\]]*[ |\n](?=[A-Z])";
string input = @"Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}