const regex = / *[\.\?!][\'"\)\]]*[ |\n](?=[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' *[\\.\\?!][\\\'"\\)\\]]*[ |\\n](?=[A-Z])', 'gm')
const str = `Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}