re = / *[\.\?!][\'"\)\]]*[ |\n](?=[A-Z])/m
str = 'Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.
Anna and her family love doing puzzles.
Anna is best at little puzzles.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end