import re
regex = re.compile(r" *[\.\?!][\'\"\)\]]*[ |\n](?=[A-Z])", flags=re.MULTILINE)
test_str = ("Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.\n\n"
"Anna and her family love doing puzzles.\n"
"Anna is best at little puzzles.\n"
"Anna and her family love doing puzzles.\n"
"Anna is best at little puzzles.\n\n\n"
"Anna and her family love doing puzzles. Anna is best at little puzzles. Anna and her family love doing puzzles. Anna is best at little puzzles.\n\n"
"Anna and her family love doing puzzles.\n\n"
"Anna is best at little puzzles.\n\n"
"Anna and her family love doing puzzles.\n\n"
"Anna is best at little puzzles.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")