using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[_a-zA-Z]\w*\s*(\[.*\])?";
string input = @"foo
bar[1]
baz[1:5:1]
qux[[1,2,3]]
This does not work:
foo + bar[1] + baz[1:10:var1[2+1]] + qux[[1,2,int(var2)]] + bob[len(""foobar"")] + func() + func2 (var3[0])
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}