$re = '/[_a-zA-Z]\w*\s*(\[.*\])?/m';
$str = 'foo
bar[1]
baz[1:5:1]
qux[[1,2,3]]
This does not work:
foo + bar[1] + baz[1:10:var1[2+1]] + qux[[1,2,int(var2)]] + bob[len("foobar")] + func() + func2 (var3[0])
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);