package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[_a-zA-Z]\w*\s*(\[.*\])?`)
var str = `foo
bar[1]
baz[1:5:1]
qux[[1,2,3]]
This does not work:
foo + bar[1] + baz[1:10:var1[2+1]] + qux[[1,2,int(var2)]] + bob[len("foobar")] + func() + func2 (var3[0])
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}