#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(input)(?:\s+type=([\'"]?)(?<type>[^\'"]+)\2)?(?:\s+name=([\'"]?)(?<name>[^\'"]+)\4)?(?:\s+value=([\'"]?)(?<value>[^\'"]+)\6)?\s*>"
Local $sString = "<input type='hidden' name='student' value=9208>" & @CRLF & _
"<input type='hidden' name='student' value='9208'>" & @CRLF & _
"<input type='hidden' name='student' value="9208">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")