const regex = /<(input)(?:\s+type=([\'"]?)(?<type>[^\'"]+)\2)?(?:\s+name=([\'"]?)(?<name>[^\'"]+)\4)?(?:\s+value=([\'"]?)(?<value>[^\'"]+)\6)?\s*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(input)(?:\\s+type=([\\\'"]?)(?<type>[^\\\'"]+)\\2)?(?:\\s+name=([\\\'"]?)(?<name>[^\\\'"]+)\\4)?(?:\\s+value=([\\\'"]?)(?<value>[^\\\'"]+)\\6)?\\s*>', 'gm')
const str = `<input type='hidden' name='student' value=9208>
<input type='hidden' name='student' value='9208'>
<input type='hidden' name='student' value="9208">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}