re = /<(input)(?:\s+type=([\'"]?)(?<type>[^\'"]+)\2)?(?:\s+name=([\'"]?)(?<name>[^\'"]+)\4)?(?:\s+value=([\'"]?)(?<value>[^\'"]+)\6)?\s*>/m
str = '<input type=\'hidden\' name=\'student\' value=9208>
<input type=\'hidden\' name=\'student\' value=\'9208\'>
<input type=\'hidden\' name=\'student\' value="9208">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end