import re
regex = re.compile(r"<(input)(?:\s+type=([\'\"]?)(?<type>[^\'\"]+)\2)?(?:\s+name=([\'\"]?)(?<name>[^\'\"]+)\4)?(?:\s+value=([\'\"]?)(?<value>[^\'\"]+)\6)?\s*>", flags=re.MULTILINE)
test_str = ("<input type='hidden' name='student' value=9208>\n"
"<input type='hidden' name='student' value='9208'>\n"
"<input type='hidden' name='student' value=\"9208\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")