$re = '/<(input)(?:\s+type=([\'"]?)(?<type>[^\'"]+)\2)?(?:\s+name=([\'"]?)(?<name>[^\'"]+)\4)?(?:\s+value=([\'"]?)(?<value>[^\'"]+)\6)?\s*>/m';
$str = '<input type=\'hidden\' name=\'student\' value=9208>
<input type=\'hidden\' name=\'student\' value=\'9208\'>
<input type=\'hidden\' name=\'student\' value="9208">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);