using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^_]+_[^_]+\.xml$";
string input = @"AB_x-y-z_XX1234567890_84481.xml
test2 = 'x-y-z_XX1234567890_84481.xml
test3 = XX1234567890_84481.xml";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}