re = /[^_]+_[^_]+\.xml$/m
str = 'AB_x-y-z_XX1234567890_84481.xml
test2 = \'x-y-z_XX1234567890_84481.xml
test3 = XX1234567890_84481.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end