$re = '/[^_]+_[^_]+\.xml$/m';
$str = 'AB_x-y-z_XX1234567890_84481.xml
test2 = \'x-y-z_XX1234567890_84481.xml
test3 = XX1234567890_84481.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);