import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^_]+_[^_]+\\.xml$";
final String string = "AB_x-y-z_XX1234567890_84481.xml\n"
+ "test2 = 'x-y-z_XX1234567890_84481.xml\n"
+ "test3 = XX1234567890_84481.xml";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}