package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^_]+_[^_]+\.xml$`)
var str = `AB_x-y-z_XX1234567890_84481.xml
test2 = 'x-y-z_XX1234567890_84481.xml
test3 = XX1234567890_84481.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}