const regex = /^[[:alnum:]]{3}---[[:alnum:]]{2}-[[:alnum:]]{9}-[[:alnum:]]{4}.gvt1.com$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[[:alnum:]]{3}---[[:alnum:]]{2}-[[:alnum:]]{9}-[[:alnum:]]{4}.gvt1.com$', '')
const str = `rr1---sn-pjvo2aopq-jb3e.gvt1.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}