$re = '/^[[:alnum:]]{3}---[[:alnum:]]{2}-[[:alnum:]]{9}-[[:alnum:]]{4}.gvt1.com$/';
$str = 'rr1---sn-pjvo2aopq-jb3e.gvt1.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);