import re
regex = re.compile(r"^[[:alnum:]]{3}---[[:alnum:]]{2}-[[:alnum:]]{9}-[[:alnum:]]{4}.gvt1.com$")
test_str = "rr1---sn-pjvo2aopq-jb3e.gvt1.com"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")