import Foundation
let pattern = #"^[[:alnum:]]{3}---[[:alnum:]]{2}-[[:alnum:]]{9}-[[:alnum:]]{4}.gvt1.com$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"rr1---sn-pjvo2aopq-jb3e.gvt1.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}