using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)^.*?(?:\s|^)?(?<time>(?<!\d)(?:0?\d[012]?)(?:-|:|\.)[0-5]\d(?:-|:|\.)[0-5]\d.*(?:a|A|p|P)(?:m|M)).*";
string input = @"The time is 12-jan-20 12:11:32.1112 AM.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}