$re = '/(?s)^.*?(?:\s|^)?(?<time>(?<!\d)(?:0?\d[012]?)(?:-|:|\.)[0-5]\d(?:-|:|\.)[0-5]\d.*(?:a|A|p|P)(?:m|M)).*/m';
$str = 'The time is 12-jan-20 12:11:32.1112 AM.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);