import Foundation
let pattern = #"(?s)^.*?(?:\s|^)?(?<time>(?<!\d)(?:0?\d[012]?)(?:-|:|\.)[0-5]\d(?:-|:|\.)[0-5]\d.*(?:a|A|p|P)(?:m|M)).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"The time is 12-jan-20 12:11:32.1112 AM."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)