import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^.*?(?:\\s|^)?(?<time>(?<!\\d)(?:0?\\d[012]?)(?:-|:|\\.)[0-5]\\d(?:-|:|\\.)[0-5]\\d.*(?:a|A|p|P)(?:m|M)).*";
final String string = "The time is 12-jan-20 12:11:32.1112 AM.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}