re = /(?s)^.*?(?:\s|^)?(?<time>(?<!\d)(?:0?\d[012]?)(?:-|:|\.)[0-5]\d(?:-|:|\.)[0-5]\d.*(?:a|A|p|P)(?:m|M)).*/m
str = 'The time is 12-jan-20 12:11:32.1112 AM.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end