import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?>1(?:01)*0?|0(?:10)*1?)\\b";
final String string = "no binary numbers here 3434.\n"
+ "Hey friend this is a 1.\n"
+ "Those are 1001, 1010, 1011, 1100, 1101\n"
+ "This is a long value 10101010101 and this one as well 1010101010101011\n"
+ "0 + 0 is a also a 0.\n"
+ "1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}