import Foundation
let pattern = #"\b(?>1(?:01)*0?|0(?:10)*1?)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
no binary numbers here 3434.
Hey friend this is a 1.
Those are 1001, 1010, 1011, 1100, 1101
This is a long value 10101010101 and this one as well 1010101010101011
0 + 0 is a also a 0.
1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)